Kiazen Central - Working rules backlog
Update
We are continuing to work on a fix for this issue.
Posted Sep 23, 2024 - 12:55 PDT
Identified
The issue has been identified and a fix is being implementd. The backlog will take some time be processed.
Posted Sep 19, 2024 - 14:45 PDT
Investigating
We are currently investigating this issue.
Posted Sep 19, 2024 - 11:18 PDT
This incident affects: Central - Working Rules.